The Problem OAuth Solves
Understanding why we need delegated authorization
Resources
- RFC 6749 - OAuth 2.0The OAuth 2.0 Authorization Framework specification
- RFC 7636 - PKCEProof Key for Code Exchange specification
- RFC 9700 - OAuth Security BCPCurrent guidance on PKCE, token protection and secure OAuth deployments
- RFC 6750 - Bearer TokensBearer Token Usage specification
- OpenID Connect CoreOpenID Connect Core 1.0 specification
- oauthlib (Python)Python OAuth library for implementing OAuth providers and clients